How to downgrade Tensorflow | How to install a specific version of TensorFlow

Pip allows specifying the version

pip install tensorflow==1.1

if it is not working then add sudo

Note: If Tensorflow is already installed then first it will uninstall than one then it will install your one.

OUTPUT:

$ sudo pip3 install tensorflow==1.1Password:The directory '/Users/admin/Library/Caches/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.The directory '/Users/admin/Library/Caches/pip' or its parent directory is not owned by the current user and caching wheels has been disabled. check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.Collecting tensorflow==1.1  Downloading https://files.pythonhosted.org/packages/73/9f/22a5381e58d3ee2bb93956c8b901273e2d90b67c87d8b7c55c54d14d4404/tensorflow-1.1.0-cp36-cp36m-macosx_10_11_x86_64.whl (31.3MB)    100% |████████████████████████████████| 31.3MB 1.1MB/s Requirement already satisfied: wheel>=0.26 in /anaconda3/lib/python3.6/site-packages (from tensorflow==1.1) (0.31.1)Requirement already satisfied: protobuf>=3.2.0 in /anaconda3/lib/python3.6/site-packages (from tensorflow==1.1) (3.6.1)Requirement already satisfied: werkzeug>=0.11.10 in /anaconda3/lib/python3.6/site-packages (from tensorflow==1.1) (0.14.1)Requirement already satisfied: numpy>=1.11.0 in /anaconda3/lib/python3.6/site-packages (from tensorflow==1.1) (1.14.3)Requirement already satisfied: six>=1.10.0 in /anaconda3/lib/python3.6/site-packages (from tensorflow==1.1) (1.11.0)Requirement already satisfied: setuptools in /anaconda3/lib/python3.6/site-packages (from protobuf>=3.2.0->tensorflow==1.1) (39.1.0)Installing collected packages: tensorflow  Found existing installation: tensorflow 1.10.1    Uninstalling tensorflow-1.10.1:      Successfully uninstalled tensorflow-1.10.1Successfully installed tensorflow-1.1.0

 

you may select any version from “(from versions: 1.2.0rc2, 1.2.0, 1.2.1, 1.3.0rc0, 1.3.0rc1, 1.3.0rc2, 1.3.0, 1.4.0rc0, 1.4.0rc1, 1.4.0, 1.5.0rc0, 1.5.0rc1, 1.5.0, 1.5.1, 1.6.0rc0, 1.6.0rc1, 1.6.0, 1.7.0rc0, 1.7.0rc1, 1.7.0)”